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Introduction 
This chapter includes the following topics: 

 Purpose 

 Overview 

 Additional help 

Purpose 

This document provides guidance on how to install and configure the Fujitsu DeskView Solution. It includes 

directions on installing all required platform components, such as the Symantec Installation Manager and the 

Symantec Management Console.  

Overview 
DeskView is a client management software developed by Fujitsu Technology Solutions.  Optimized for Fujitsu 

hardware, it helps to minimize the total cost of ownership of managing your client hardware infrastructure. Based on 

industry standards, DeskView manages STYLISTIC tablet PCs, ESPRIMO Mobile and LIFEBOOK Professional 

Notebooks, FUTRO Thin Clients, SCENIC and ESPRIMO Professional PCs, CELSIUS Workstations. DeskView 

makes use of the features that are offered by the system for inventory management, system health monitoring, 

remote BIOS configuration and updates, and more. DeskView lets you manage your client infrastructure completely 

from your desk.  
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Additional help 

Additional support resources, including release notes, are available in the Symantec Altiris Knowledge Base 

http://kb.altiris.com.  

Additional documentation can be found on the Symantec documentation site at: 

http://www.altiris.com/support/documentation.aspx.  

For additional assistance with the installation, configuration, or utilization of DeskView solution, please contact the 

DeskView support team at deskview@ts.fujitsu.com. 

http://kb.altiris.com/
http://www.altiris.com/support/documentation.aspx
mailto:deskview@ts.fujitsu.com?subject=Support%20Help%20with%20DeskView%20Product
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Prerequisites 
This chapter includes the following topics: 

 Software Platforms 

 Software Components 

 Recommended Hardware 

Software Platforms 

Install and configure the following software platforms before you install DeskView: 

 Microsoft Windows Server 2003 32 bit. 

 Microsoft SQL 2000 or SQL 2005 Database Engine.  

 Microsoft Internet Information Services with ASP.NET.  

Software Components 

Install and configure the following software platforms before you install DeskView: 

 Microsoft ASP.NET Framework 3.5.  

Recommended Hardware 

We recommend the following hardware: 

 Server-class system  with Dual processor, dual-core, 2.0 GHz CPU or greater  

 2 GB RAM or greater  

 Storage Volume 1: RAID 1, 36 GB or greater (operating system)  

 Storage Volume 2: RAID 1, 72 GB or greater (database, logs, etc.)  
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Installing and configuring 
This chapter includes the following topics: 

 Verifying prerequisites 

 Installing the Symantec Installation Manager 

 Installing the Fujitsu DeskView Solution 

 Discovering Computers 

 Installing the Altiris Agent 

 Discovering Systems from Fujitsu Technology Solutions 

 Installing the DeskView Agent 

 Start Managing your Client Computers 

Verifying prerequisites 

While installing and configuring the DeskView solution is fairly straightforward, you must complete the following 

steps as outlined to ensure full functionality. Performing these steps out of order might cause reduced functionality 

or certain features might not work or be accessible.  

To verify prerequisites 

1. Check that Microsoft SQL 2000 or 2005 Database engine is installed, configured, and functioning properly.  

2. Check that Microsoft Internet Information Services with ASP.NET is installed, configured, and functioning 

properly. 
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Installing the Symantec Installation Manager 

The Symantec Installation Manager (SIM) is used to check for prerequisites.  The SIM assists with the download 

and installation of the Notification Server, all necessary components and solutions.  The SIM also ensures that these 

steps are performed in the appropriate order.  

Before running SIM, ensure that your server is prepared with the appropriate software and hardware prerequisites. 

 See Software Platforms 

 See Software Components 

 See Recommended Hardware 

To install the Symantec Installation Manager  

1. Navigate to the Symantec Trialware Product website at https://www4.symantec.com/offer?a_id=55151 

2. In the Export and Eligibility page click I Agree. 

3. Fill out the product information survey and click Continue. 

4. In the Software Download page click Download Now next to the Fujitsu Technology Solutions DeskView 

for Business Clients software package. 

https://www4.symantec.com/offer?a_id=55151
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5. Save the Symantec_SIM.exe file to a folder of your choice. 

6. Once the file has been downloaded Run the Symantec_SIM.exe file. 

7. If .NET Framework 3.5 is not installed, click Yes in the dialog box that asks you to install it, and install it. 

.NET Framework 3.5 is a prerequisite for the installation of Symantec Installation Manager. 

8. In the Welcome dialog box, click Next. 
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9. In the License Agreement dialog box, check I accept the terms in the license agreement, and click Next. 

10. In the Destination Folder dialog box, click Begin install to install the files in the default location. 

To install the files in a different location, click Browse, and specify a different location. 

 

11. In the final dialog box, click Finish. 
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12. By default, the Automatically Launch Symantec Installation Manager option is selected on this page. This 

option opens Symantec Installation Manager to the Install New Products page.  

Installing the Fujitsu DeskView Solution 

When you run Symantec Installation Manager, a wizard walks you through a set of pre-installation tasks. These 

tasks configure the installation, Notification Server, and the SQL Server.   

To install the Fujitsu DeskView Solution 

1. Start Symantec Installation Manager. 

When you complete the installation of Symantec Installation Manager, it starts by default. You can also 

start it on the Start menu at Programs > Altiris > Symantec Installation Manager > Symantec Installation 

Manager. 

2. Click Install New Products.  

3. Verify that the filter is set to Suites.  

4. Check DeskView Integration for Symantec Management Platform 7 (Business Clients) and click Next. 
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5. Check the Install Documentation and Install Language Support Options. 

6. Click Next.  

7. On the End User License Agreement page, check I accept the terms in the license agreements, and click 

Next. 

8. On the Contact Information page, type the answers for the requested information, and click Next. 
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9. On the Install Readiness Check page, verify that the computer meets the minimum requirements, and click 

Next. 
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10. On the Notification Server Configuration page, configure the Notification Server by entering the following 

information: 

 Username: Enter the account credentials that you will use to install the Notification Server. The 

user name must be a Windows user with local administrator rights to the Notification Server 

computer and a user with rights to create a database on the SQL server, which you specify in the 

next screen. 

 Password: Enter the password for the username provided above. 

 Web site: Enter the name of the website that you would like to install Notification Server on. 

 Fully Qualified Domain Name: Enter the Fully Qualified Domain Name of the Notification 

Server computer. 

 Configure my email information now: Enter the SMTP server, email address, and account 

information you wish to use for sending notifications. Alternatively, you can skip this step to 

configure these settings at a later time. 

11. Click Next. 
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12. On the Database Configuration page, configure the database by entering the following information: 

 SQL Server name: Enter the name of your SQL Server, including the instance name if you did 

not use the default instance.  

 Logon information:  Enter the authentication type. Windows Authentication is recommended. 

Enter the SQL user name and password if using SQL Authentication. 

 Database Name: Enter the database name. You can specify a database name or accept the default 

Symantec_CMDB name. Alternatively, the Use existing option lets you connect to a previously 

created database that exists on the specific SQL server instance. 

13. Click Next. 
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14. On the Review Installation Details page, click Begin install to begin the installation. 
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15. On the Installation Complete page, click Finish. 

 

Discovering Computers 

Discovery lets you find the hostnames of the computers where you can install the Altiris Agent. You can discover 

computers on the network using a domain or a workgroup search. 

For more information on resource discovery, see the Symantec Management Platform Help. 

To discover computers 

1. In the Symantec Management Console, on the Actions menu, click Discover >Import Domain 

Membership/WINS. 

2. In the Add Domain box, type the domain name, and then click the Add symbol. 

3. Check Domain Membership and click Discover Now. 

4. As the discovery process finishes, click View discovery reports. 

5. Open a report to view the list of discovered computers. 

For example, right-click the Discovered Computers report, and then click Open. 
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Installing the Altiris Agent 

The Altiris Agent is a program that you install on the computers you want to manage, allowing the Symantec 

Management Platform and solutions to get information from and interact with your computers. The agent enables 

computers to receive configuration information from and send data to Notification Server and helps download 

packages as well as tasks and jobs. The agent lets you change settings on the managed computer and install and 

manage various solution-specific plug-ins. 

You must install the Altiris Agent on the computers you want to manage with DeskView. 

There are three methods in which you can install the Altiris Agent on client machines.  The methods are: 

1. Manual Push: Pushing is initiated from the Symantec Management Console and installs the Altiris Agent 

immediately. You can install the Altiris Agent on any number of computers in the same push operation. 

You can also customize the installation options for each push operation. 

2. Manual Pull: Pulling is initiated from the computer on which the Altiris Agent is to be installed. This 

operation lets you work around firewalls and the network access limitations that may prevent push 

installations to remote computers. For UNIX, Linux, and Mac computers, you need to use this method if 

SSH or Telnet is not available 

3. Scheduled Push: A scheduled Altiris Agent installation is performed at a defined time, unlike the manual 

push installations which are performed immediately. You can push the Altiris Agent to the computers in an 

organizational group, filter, or resource target, or the computers that have selected resources. 

For more information on the Altiris Agent, see the Symantec Management Platform Help. 
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To install the Altiris Agent through the Manual Push Method 

1. In the Symantec Management Console, on the Actions menu, click Agents/Plugins > Push Altiris Agent. 

2. On the Altiris Agent Installation page, install the Altiris Agent to computers in your environment. 

For more information on how to install the Altiris Agent, see the Symantec Management Platform Help 

(Press F1 or click Help > Context in the Symantec Management Console). 

 

Discovering Systems from Fujitsu Technology Solutions 

Before you can manage computers using DeskView, you must identify the computers as manageable systems from 

Fujitsu Technology Solutions. To do this, you must install the DeskView Discovery Agent to computers in your 

environment.  

After you install the DeskView Discovery Agent on systems from Fujitsu Technology Solutions, it will report basic 

inventory data to Notification Server and identify the computer resources as DeskView manageable systems.  

If you have a previous version of the DeskView Discovery Agent already installed on the managed computers, we 

recommend that you upgrade the DeskView Discovery Agent. 

To install the DeskView Discovery Agent 

1. In the Symantec Management Console, on the Home menu, click DeskView. 
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2. In the left pane, click Agents and Plug-ins > DeskView Discovery Agent - Install. 

3. Turn on the policy. 

To turn on the policy, at the upper right of the page, click the colored circle, and then click On. 

4. Click Save changes. 

 

 

To upgrade the DeskView Discovery Agent 

1. In the Symantec Management Console, on the Home menu, click DeskView. 

2. In the left pane, click Agents and Plug-ins > DeskView Discovery Agent - Update. 

3. Turn on the policy. 

To turn on the policy, at the upper right of the page, click the colored circle, and then click On. 

4. Click Save changes. 

 

To view discovered systems from Fujitsu Technology Solutions 

1.  In the Symantec Management Console, on the Home menu, click DeskView. 

2. In the left pane, click Agent and Plug-in Filters. 

3. To view new discovered systems from Fujitsu Technology Solutions, click DeskView Agent Not 

Installed. 
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4. To view discovered systems from Fujitsu Technology Solutions with DeskView Agent already installed, 

click DeskView Agent Installed. 

Installing the DeskView Agent 

The DeskView Agent is a client software package that includes a DeskView Agent as well as the DeskView Client 

tools. You can deploy this package remotely on the manageable systems from Fujitsu Technology Solutions using 

the Install Recommended DeskView Agent policy. Another option is to use the dedicated DeskView Agent 

6.xx.yyyy *)- Install policy. 

*) The appropriate version of DeskView Agent. 

We recommend that you use the Install Recommended DeskView Agent policy and let the DeskView software 

choose which version of the agent to install onto each of the target computers. 

Before you install the DeskView Agent, you must discover systems from Fujitsu Technology Solutions.  

To install the DeskView Agent 

1. In the Symantec Management Console, on the Home menu, click Desk View. 

2. Do one of the following: 

 In the left pane, click Agents and Plug-ins > Install Recommended DeskView Agent. 

 

 In the left pane, click Agents and Plug-ins > DeskView Agent 6.xx.xxxx - Install. 
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3. If you want to install ASF components, check Install ASF components on ASF capable computers. 

4. If you want to install DeskView Presentation, check Install DeskView presentation mode. 

DeskView Presentation is a button in the taskbar that lets users turn off the screensaver while running a 

presentation. 

5. If you want to reinstall the existing DeskView client components, check Force existing components 

reinstallation. 

This is useful when you want to repair the DeskView components that are already installed on the client 

system. 

6. Sometimes a restart is required to complete the installation or upgrade of the DeskView Agent. If you want 

to restart the target system after running the task, under Power Management, check Restart the computer 

after task. 

7. If you want, under Applied To, edit the targets to which the policy is applied. 

8. Turn on the policy. 

To turn on the policy, at the upper right of the page, click the colored circle, and then click On. 

9. Click Save changes.  
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Start Managing your Client Computers 

When you install the DeskView Agent on client computers, the DeskFlash, DeskUpdate, DeskView BIOS Settings, 

DeskView Diagnostics, DeskView Energy Management, DeskOff, DeskView Security, and DeskView Serial  

numbers client tools are installed as part of that installation. 

You can run these DeskView tools using tasks or task-based policies. 

If you want a tool to run immediately or on a specific schedule, use tasks to run the tool. 

However, the peculiarity of the task is the following: If a client computer happens to be offline or turned off at the 

time the task is scheduled to run, the task will fail to run on that computer. 

If you want to make sure that, sooner or later, all computers run the tool, use task-based policies. When task-based 

policies are turned on, they are active at all times. When a computer that is turned off comes back online, it receives 

and executes the policy. 

To use tasks 

1. In the Symantec Management Console, on the Home menu, click DeskView. 

2. In the left pane, click Tasks. 

3. Expand the appropriate folder and click the task you want to run. 

4. In the right pane, configure the task. 

For help, in the Symantec Management Console, press F1 or click Help > Context. 

5. Run the task one time or on a schedule. 

For information on running tasks, see the Symantec Management Platform Help. 
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To use task-based policies 

1. In the Symantec Management Console, on the Home menu, click DeskView. 

2. In the left pane, click Policies.  

3. Expand the appropriate folder and select the policy you want to run. 

4. In the right pane, configure the settings. 

For help, in the Symantec Management Console, press F1 or click Help > Context 

5. Configure the scheduling options. 

6. Turn on the policy. 

To turn on the policy, at the upper right of the page, click the colored circle, and then click On. 

7. Click Save changes. 
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Appendix A 


